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iSync is an application that allows users to sync their devices with data on their computers. iSync Plug-in
Maker is a developer tool that allows you to build, test, and release iSync device plug-ins. iSync Plug-in Maker
contains automated tests that communicate directly with the device. However, you must also run the manual
tests described in this document to fully qualify your iSync plug-in before shipping. These manual tests
involve adding, modify, and deleting records on both the device and computer. You use Apple applications
to modify records on the computer and development tools to help set up certain scenarios.

Note:  The Open Mobile Alliance (OMA) Data Synchronization Working Group is developing specifications
for data synchronization that includes SyncML technology. This book refers to the data synchronization
technology as SyncML.

Who Should Read This Document?

You should read this document if you are building an iSync device plug-in using iSync Plug-in Maker. After
editing, testing, and exporting your plug-in using iSync Plug-in Maker, use this guide to run manual test
suites. You should be familiar with end-user applications on the computer to run these tests and the
Syncrospector developer tool.

Organization of This Document

The tests in this document are organized by categories from general purpose tests to specific database tests.
There are also categories for sync modes and stress testing. The document contains the following chapters:

 ■ “Common Steps” (page 11) contains common set up and steps used by most tests. Read this chapter
first.

 ■ “General Tests” (page 15) contains tests that pertain to all devices regardless of the SyncML features
they support.

 ■ “Initial Sync Tests” (page 17) contains tests that pertain to the first time the device syncs.

 ■ “Sync Mode Tests” (page 21) contains tests that pertain to different sync modes.

 ■ “Cancellation Tests” (page 23) contains tests that cancel syncing.

 ■ “Stress Tests” (page 27) contains tests that exceed the limits of the capacity of the device.

 ■ “Calendar Tests” (page 31) contains tests specific to the Calendars database.

 ■ “Contacts Tests” (page 29) contains tests specific to the Contacts database.

 ■ “Miscellaneous Tests” (page 41) contains miscellaneous tests that do not fit into any of the above
categories.

Who Should Read This Document? 9
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Note:  This document uses Apple terms for records rather than vCal and vCard terms. For example, a “task”
in iCal is the same as a “to do” in vCal.

See Also

If you need to build an iSync plug-in, read iSync Plug-in Maker User Guide before reading this document.

If you use Syncrospector to test your plug-in, read Sync Services Tutorial to learn more about how to use this
tool.
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This chapter covers some common steps when testing iSync plug-ins. Before running any tests the device
needs to connected to the computer. It is also recommended that you turn Sync Alert panels on so you can
observe what records are being synced. You also need to be familiar with running Apple Applications such
as iCal and Address Book. Some tests also use the Syncrospector developer tool.

Connecting to a Device

If the device uses USB only, then connect the USB cable to the device and computer before running any
tests. There is no other setup required to use USB.

If the device uses Bluetooth only, then pair the device with the computer before running any tests. This step
needs to be done only once per device. Use the Bluetooth pane in System Preferences to pair a Bluetooth
device. Choose Help > System Preferences Help to learn more about setting up a Bluetooth connection.

If the device uses both Bluetooth and USB, then run some of the tests using Bluetooth and others using USB.
Note that if you pair a Bluetooth device with the computer, you can no longer use the USB connection.
Therefore, for devices that support both, delete the device from the Bluetooth pane in System Preferences
before using the USB connection.

Setting the Data Change Alert

Before running any of the tests in this document, you should configure the iSync preferences so an alert
appears each time the device changes the state of the truth—each time the device adds, modifies, or deletes
records—as follows:

 ■ To set the data change alert to “any” in iSync, choose iSync > Preferences, enable the “Show Data Change
Alert when” option, and choose “any” from the adjacent pop-up menu.

When a Sync Alert panel appears as shown in Figure 1-1, click the triangle at the bottom of the panel to
reveal more information about the changes. Use this panel to verify the changes and optionally, cancel
the sync session.

Connecting to a Device 11
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Figure 1-1 Sync Alert panel

Using Apple Applications

Some of the steps described in this document involve running Apple applications and tools to set up the
records on the computer. You are expected to be able to perform common tasks such as adding records to
the computer and syncing the device. You should be familiar with these Apple applications before running
these tests:

 ■ Use iSync to sync the device.

For example, assuming your iSync plug-in is installed, launch iSync and choose Devices > Add Device.
Double-click the device in the Add Device window to add it to iSync. Select the device in the iSync
window to configure options such as which databases to sync to the device. Choose Sync Devices to
sync the device.

Choose Help > iSync Help to learn more about iSync.

 ■ Use Address Book to add, delete, and modify contacts on the computer.

For example, launch Address Book and click the plus button at the bottom of the Name column to add
a contact. Choose Help > Address Book to learn more about Address Book.

 ■ Use iCal to add, delete, and modify events and tasks on the computer.

12 Using Apple Applications
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For example, launch iCal and double-click anywhere in the calendar view to create an event. Use the
information sheet that appears on the right side of the iCal window to edit the fields of an event.

Choose Help > iCal to learn more about iCal.

Note:  The first time you run iCal, you enable the Calendars database in iSync.

Note that most tests in this document assume that when you add a record, you populate all fields for that
record.

Using Syncrospector

Some of the tests require you to use this developer tool, Syncrospector, located in
/Developer/Applications/Utilities, to help debug your sync sessions. You can use Syncrospector
during testing to force sync modes such as slow, fast, or reset. Read Sync Services Tutorial to learn more about
Syncrospector.

Using Syncrospector 13
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The tests in this section are basic and apply to all devices. Read “Common Steps” for how to turn on data
change alerts before running these tests.

These tests, except “Add Device,” assume that you have iSync launched, the device is selected in the iSync
window, and syncing is enabled for the device. These are some common steps specific to this chapter:

 ■ To enable syncing for a device, select the device and select the “Turn on <device> synchronization” option
in the iSync window.

Device syncing is turned on by default.

 ■ To sync the device, add the device (if it is not already added), and click the Sync Devices button. Bluetooth
devices should already be paired using System Preferences before running any of these tests.

Add Device

Tests adding the device to iSync—for example, tests that the correct icon appears.

If the device uses Bluetooth, then all of the tests in this document assume that you already paired the device
with the computer. This step needs to be done only once per device. Use the Bluetooth pane in System
Preferences to pair a Bluetooth device. Choose Help > System Preferences Help to learn more about setting
up a Bluetooth connection.

If you are testing a USB connection, plug in the device via USB before following these steps.

Steps

1. Add device in iSync.

Verify that the device appears with the correct name and icon in the Add Device and iSync windows.

Sync, Repower, Sync

Tests syncing after powering off the device. Verifies that the Sync Alert panel appears when the connection
is lost.

Add Device 15
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Steps

1. Sync.

2. Power off device.

3. Sync.

An Sync Alert panel should appear saying that it cannot connect to the device.

4. Power on device.

5. Sync.

This sync should succeed.

Enable and Disable Databases

Tests enabling and disabling different databases in iSync.

Steps

1. Add a contact to the computer and to the device.

2. Add an event to the computer and to the device.

3. Enable Contacts and disable Calendars in the iSync window.

4. Sync.

Verify that changes are made to Contacts only.

5. Disable Contacts and enable Calendars in the iSync window.

6. Add a contact to the computer and to the device.

7. Sync.

Verify that changes are made to Calendars only.

16 Enable and Disable Databases
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The tests in this chapter cover syncing the device for the first time which is called initial sync. There are
different types of initial syncs that need to be tested. These tests assume that you have iSync launched, the
device is selected in the iSync window, and syncing is enabled for the device. Read “Common Steps” for set
up instructions before running these tests.

In addition, you should configure the iSync preferences so an alert appears each time the device changes
the state of the truth—each time the device adds, modifies, or deletes records—as follows:

 ■ To set the data change alert to “any” in iSync, choose iSync > Preferences, enable the “Show Data Change
Alert when” option, and select “any” from the adjacent pop-up menu.

When a Sync Alert panel appears, click the triangle at the bottom of the panel to reveal more information
about the changes. Use this panel to verify the changes and optionally, cancel the sync session.

Some of the following tests require records on the device before running an initial sync. Optionally, follow
these steps to set up a device for these tests using iSync:

1. Add contacts and calendars to the computer that you want to be on the device.

Create a group in Address Book and add the contacts to that group. Create a calendar in iCal and add
the events to that calendar.

2. Launch iSync and select the device icon.

3. Choose the Contacts group from the Synchronize pop-up menu.

4. Select the Calendars group from the Calendars > Selected scroll view.

5. Choose Devices > Reset Device from the iSync menu and click Reset in the alert panel.

Wait for iSync to sync the device, which adds the selected records to the device.

6. Click the device icon and choose Devices > Remove Device and click OK in the alert panel.

7. Delete all the records on the computer that were added to the device.

8. Reset the Sync Services server by launching Syncrospector, choosing Window > Show Sync Plans, and
clicking the Reset Server button.

These are the common steps used in this chapter:

 ■ To perform an initial merge sync, choose “Merge data on computer and device” from the “For first sync”
pop-up menu in the iSync window.

 ■ To perform an initial erase sync, choose “Erase data on device then sync” from the “For first sync” pop-up
menu in the iSync window.

 ■ To reset the device, choose Device > Reset Device or Device > Reset All Devices from the iSync menu.
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This is an alternate way to perform an initial erase sync.

Merge with No Data on Device

Tests initial syncs where 0 records are on the device and some records are on the computer.

Steps

1. Add a contact to the computer.

2. Add an event to the computer.

3. Add a task to the computer.

4. Make sure there are 0 contacts and 0 events on the device.

5. Perform an initial merge sync.

Verify that the records on the computer are now on the device.

Merge with Data on Computer and Device

Tests initial merge syncs when records are on the device and on the computer.

Steps

1. Add some contacts and events to the device.

2. Add some different contacts and event to the computer.

3. Perform an initial merge sync.

Verify that the records on the device are now on the computer and vice-versa.

Merge with Many Records on Computer and Device

Tests syncing with many records on the device and computer.

18 Merge with No Data on Device
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Steps

1. Add many contacts and events (2000 or more records) to the computer.

2. Add many different contacts and events to the device.

3. Perform an initial merge sync.

Verify that the records on the device are now on the computer and vice-versa.

Erase with Data on Device

Tests initial erase sync when the device contains many records.

Steps

1. Add many contacts and events (2000 or more records) to the device.

2. Add a few different contacts and events to the computer.

3. Enable Contacts and Calendars in the iSync window.

4. Initial erase sync.

Verify that existing records on the device are deleted and that records from the computer are added
correctly.

5. Repeat steps 1-4 for the Contacts database only and Calendars database only.

Erase with Data on Computer

Tests initial erase sync when the device contains no records and the computer contains records

Steps

1. Add many contacts and events to the computer.

2. Enable Contacts and Calendars in the iSync window.

3. Initial erase sync.

Verify that all the records on the computer are on the device.

4. Repeat steps 1-3 for the Contacts database only and Calendars database only.

Erase with Data on Device 19
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The tests in this chapter cover the different sync modes. Read “Common Steps” for how to turn on data
change alerts before running these tests.

These are the common steps specific to this chapter:

 ■ To perform an initial erase sync, choose “Erase data on device then sync” from the “For first sync” pop-up
menu on the iSync window.

 ■ To perform a master reset device, follow the instructions in the device manufacturer’s manual.

 ■ To force a slow sync, launch Syncrospector, select the device from the Clients table, choose Slow Sync
from the Sync Mode menu, and sync the device.

Master Reset Device and Sync

Tests syncing after a master reset of the device.

At the SyncML level, the device should reset its anchors for all the data classes. If it fails to do this properly,
then iSync cannot determine if the device was reset and assumes that the user deliberately deleted all the
records and iSync deletes all the records on the computer.

Steps

1. Add contacts, events, and tasks to the computer.

2. Perform an initial erase sync.

3. Perform a master reset of the device.

4. Force a slow sync.

No data change alert panels should appear during syncing.

Slow Sync Using Syncrospector

Tests slow syncing.

Master Reset Device and Sync 21
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Steps

1. Add some contacts and events to the computer.

2. Sync.

3. Add a contact and an event to the device.

4. Sync.

Verify that a data change alert panel appears during syncing.

5. Force a slow sync.

Verify that no data change alert panel appears during syncing.

Pull the Truth Using Syncrospector

Tests the ability to refresh sync one data class or database while fast syncing the other.

Steps

1. Add contacts and events to the computer.

2. Sync.

3. Add contacts and events to the device.

4. Add contacts and events to the computer.

5. Launch Syncrospector.

6. Select the device in the Clients table.

7. Click Sync State in the lower pane and select all the Contacts entities—entity names that begin with
com.apple.contacts.

8. Choose Sync Mode > Pull the Truth.

9. Click the Sync button in Syncrospector.

The device should reset its contacts but not its calendars. The contacts on the device should be deleted
and the changes to the calendars should be correctly applied to the computer. All the changes from the
computer should be applied to the device.

10. Repeat steps 1-9 except select all the Calendars entities—entity names that begin with
com.apple.calendars.
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Tests canceling syncs during different states. Read “Common Steps” for how to turn on data change alerts
before running these tests.

These are common steps specific to this chapter:

 ■ To perform an initial merge sync, choose “Merge data on computer and device” from the “For first sync”
menu in the iSync window.

 ■ To perform an initial erase sync, choose “Erase data on device and then sync” from the “For first sync”
menu in the iSync window.

Cancel Erase Sync from Computer

Tests canceling an initial erase sync with contacts and events on the computer.

Steps

1. Add contacts to the computer.

2. Add events to the computer.

3. Perform an initial erase sync.

4. When a connection is made to the device, immediately cancel the sync using iSync.

5. Add a contact to the device.

6. Sync.

The device should recover from the first sync—that is, from the device’s point of view, abort between
SyncML package 1 and package 3.

Cancel Merge Sync from Computer

Tests canceling an initial merge sync with contacts and events on the computer.

Cancel Erase Sync from Computer 23
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Steps

1. Add contacts to the computer.

2. Add events to the computer.

3. Perform an initial merge sync.

4. When a connection is made to the device, immediately cancel the sync using iSync.

5. Add a contact to the device.

6. Sync.

The device should recover from the first sync—that is, from the device’s point of view, abort between
SyncML package 1 and package 3.

Cancel Merge Sync from DCA and Sync

Tests canceling a merge sync with records on both the device and the computer.

Steps

1. Add contacts and events to the device.

2. Add contacts and events to the computer.

3. Perform an initial merge sync.

4. When the data change alert (DCA) panel appears, press the Cancel button.

5. Sync.

The device should recover from the first sync that is, from the device’s point of view, aborted after the
end of the SyncML package 3 but before receiving package 4.

Cancel Merge Sync from Device

Tests what should happen when a user cancels an initial merge sync from the device.

Steps

1. Add contacts and events to the computer.

24 Cancel Merge Sync from DCA and Sync
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2. Perform an initial merge sync.

3. When a connection is made to the device, immediately cancel the sync from the device (if possible).

4. Add a contact to the device.

5. Sync.

The device should recover and correctly perform the last sync.

6. Repeat steps 1-6 and cancel at various stages during the sync.

Cancel Merge Sync from Device 25
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Tests in this chapter involve hardware states such as power loss and the computer going to sleep. Read
“Common Steps” for how to turn on data change alerts before running these tests.

Device Loses Power

Tests syncing while the device is low on power.

Steps

1. Add contacts and events in the computer.

2. Start a sync.

3. During sync, power off device (turn off the device or remove the battery).

4. After iSync reports a failed sync due to connection loss or not being able to connect, turn device on.

5. Sync.

Verify that the new contacts and events are on the device.

Computer Goes to Sleep

Tests syncing when the computer goes to sleep.

Steps

1. Sync.

2. Put computer to sleep while syncing.

3. Wake up computer.

4. Sync.

Verify that the device recovers from the lost connection and syncs correctly.

Device Loses Power 27
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Sync to Device with Low Memory

Tests syncing when the device is low on memory.

Steps

1. Fill up the memory on the device to it’s capacity.

It should have no space for additional contacts or events.

2. Add contacts and events to the computer that exceeds the available memory on the device.

3. Sync.

iSync should report that the device is out of memory. If it fails to do so, it probably means that the device
did not acknowledge the changes coming from the computer with the appropriate SyncML status code.

Device Out of Bluetooth Range

Tests syncing when the device is moved out of Bluetooth range.

Steps

1. Add contacts and events to the computer.

2. Start a sync.

3. During the sync, move the device out of Bluetooth range.

Verify that iSync displays an alert panel saying the device is out of Bluetooth range.

4. After a few moments, bring the device into Bluetooth range.

5. Sync.

Verify that the device recovers from the lost connection and syncs correctly.
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The tests in this chapter pertain to the Contacts database. Read “Common Steps” for how to turn on data
change alerts before running these tests.

There is one common step specific to this chapter:

 ■ To add a contact with pictures, select the contact in Address Book and click Edit. Double-click the picture
area and drag an image to the picture area.

Contact from Device

Tests adding, modifying, and deleting contacts.

This test consolidates contact mapping at a high level for contacts created and/or changed from the device
side.

Scenario 1

1. Add a contact to the device.

2. Sync.

3. Modify field values on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the contact on the device.

8. Sync.

Scenario 2

1. Add a contact to the computer.

2. Sync.

3. Modify field values on the device.

Contact from Device 29
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4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the contact on the device.

8. Sync.

Contacts with Large Pictures

Tests adding many contacts with large pictures.

Steps

1. Add many contacts with large pictures—for example, 500 contacts—to the computer .

Pictures should be 256 x 256 pixels or larger.

2. Sync.
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The tests in this chapter are specific to the Calendars database. Read “Common Steps” for how to turn on
data change alerts before running these tests.

These are common steps specific to this chapter:

 ■ To perform an initial merge sync, choose “Merge data on computer and device” from the “For first sync”
pop-up menu on the iSync window.

 ■ To force slow sync, launch Syncrospector, select the device from the Clients table, choose Slow Sync from
the Sync Mode menu, and sync the device.

 ■ To add a timed event, double-click a day in Month view in iCal and choose the type of alarm from the
“alarm” pop-up menu, and then set when you want the alarm to fire.

 ■ To add a recurrent event, double-click a day in Month view in iCal and choose how often you want the
event to occur from the “repeat” pop-up menu.

 ■ To add a all-day event, double-click a day in Month view in iCal and select the all-day option in the Info
drawer.

 ■ To add a recurrent all-day event, add an all-day event in iCal and choose how often you want the event
to occur from the "repeat" pop-up menu.

 ■ To add a multi-day all-day event, double-click a day in Month view in iCal. Then select the all-day option
and type the start and end dates (spanning multiple days) in the event's Info drawer.

 ■ To delete fields on the computer, select an event in iCal and edit the field in the Info drawer. To delete
a recurrence rule, choose None from the “repeat” pop-up menu. To delete an alarm, choose Remove
Alarm from the alarm pop-up menu. To delete text in the Notes field, click in the Notes field, press
Command-A, and press the Delete key.

 ■ To modify a repeat rule, select the event in iCal and choose another menu item in the "repeat" pop-up
menu.

Timed Events from Device

Tests adding, modifying, and deleting timed events on the device and computer.

This test consolidates calendar mapping at a high level for timed events added and/or modified on the device.

Scenario 1

1. Add a timed event to the device.

2. Sync.
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3. Modify field values on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the timed event on the device.

8. Sync.

9. Repeat steps 1-8 for all types of events that the device supports—for example, memo and anniversary.

Scenario 2

1. Add a timed event to the computer.

2. Sync.

3. Modify field values on the computer.

4. Sync.

5. Delete fields on the computer.

6. Sync.

7. Delete the timed event on the computer.

8. Sync.

9. Repeat steps 1-8 for all types of events that the device supports—for example, memo and anniversary.

Recurrent Events from Device

Tests adding, modifying, and deleting recurrent events on the device and computer. Also tests changing
recurrent events to timed events and vice-versa.

This test consolidates calendar mapping at a high level for recurrent events added and/or modified on the
device.

Scenario 1

1. Add a recurrent event to the device.

2. Sync.

3. Modify field values on the device.
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4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the recurrent event on the device.

8. Sync.

Scenario 2

1. Add a recurrent event to the device.

2. Sync.

3. Modify the repeat rule on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the recurrent event on the device.

8. Sync.

Scenario 3

1. Add a recurrent event to the computer.

2. Sync.

3. Modify field values on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the recurrent event on the device.

8. Sync.

Scenario 4

1. Add a recurrent event to the computer.
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2. Sync.

3. Modify the repeat rule on the device.

4. Sync.

5. Delete the fields on the device.

6. Sync.

7. Delete the recurrent event on the device.

8. Sync.

Scenario 5

1. Add a recurrent event to the computer.

2. Sync.

3. Change the recurrent event to a timed event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the timed event on the device.

8. Sync.

Scenario 6

1. Add a timed event to the computer.

2. Sync.

3. Change the timed event to a recurrent event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the recurrent event on the device.

8. Sync.
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All-Day Events from Device

Tests adding, modifying and deleting all-day events on the device and computer. Also tests changing all-day
events to recurrent all-day events and vice-versa.

These tests consolidate calendar mapping at a high level for all-day events added and/or modified on the
device.

Note:  Some devices refer to all day events as "memos.“

Scenario 1

1. Add an all-day event to the device.

2. Sync.

3. Modify field values on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the all-day event on the device.

8. Sync.

Scenario 2

1. Add an all-day event to the device.

2. Sync.

3. Change all-day event to a timed event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the timed event on the device.

8. Sync.
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Scenario 3

1. Add an all-day event to the computer.

2. Sync.

3. Change field values on device,

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the all-day event on the device.

8. Sync.

Scenario 4

1. Add an all-day event to the computer.

2. Sync.

3. Change a all-day event to a timed event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the timed event on the device.

8. Sync.

Scenario 5

1. Add an all-day event to the computer.

2. Sync.

3. Change the all-day event to a recurrent all-day event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the recurrent all-day event on the device.
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8. Sync.

Scenario 6

1. Add a recurrent all-day event to the computer.

2. Sync.

3. Change recurrent all-day event to a single all-day event on the device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the single all-day event on the device.

8. Sync.

Tasks from Device

Tests adding, modifying, and deleting tasks on the device and computer.

This test consolidates task mapping at a high level for tasks added and/or modified on the device.

Scenario 1

1. Add a task to the device.

2. Sync.

3. Modify field values on device.

For example, modify the priority, due date, completed, and notes fields.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the task on the device.

8. Sync.

Tasks from Device 37
2007-07-11   |   © 2007 Apple Inc. All Rights Reserved.

CHAPTER 8

Calendar Tests



Scenario 2

1. Add a task to the computer.

2. Sync.

3. Modify field values on device.

4. Sync.

5. Delete fields on the device.

6. Sync.

7. Delete the task on the device.

8. Sync.

Recurrent All-Day Event from Device

Tests adding, modifying, and deleting recurrent all-day events on the device and computer.

Note:  Some devices refer to all-day events as "memos.“

Scenario 1

1. Add a recurrent all-day event to the device.

2. Sync.

3. Modify field values on device.

4. Sync.

5. Delete the recurrent all-day event on the device.

6. Sync.

Scenario 2

1. Add a recurrent all-day event to the computer.

2. Sync.

3. Modify all field values on device.

4. Sync.
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5. Delete fields on device,

6. Sync.

7. Delete the recurrent all-day event on the device.

8. Sync.

Recurrent Multi-day All-day Event from Device

Tests adding, modifying, and deleting recurrent multi-day all-day events on the device and computer.

Note:  Some devices refer to all day events as "memos.“

Scenario 1

1. Add a recurrent multi-day all-day event to the device.

2. Sync.

3. Modify field values on device.

4. Sync.

5. Delete the recurrent multi-day all-day event on the device.

6. Sync.

Scenario 2

1. Add a recurrent multi-day all-day event to the computer.

2. Sync.

3. Modify all field values on device.

4. Sync.

5. Delete fields on device,

6. Sync.

7. Delete the recurrent multi-day all-day event on the device.

8. Sync.
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Birthday Event from Device

Tests adding birthday events on the device and modifying them on the computer. Run this test using only
devices that support birthday events.

Steps

1. Add a birthday event to the device.

2. Perform an initial merge sync.

3. Force a slow sync.

4. Using iCal, select the birthday event in the current year and modify the subject field of the event and all
future events.

5. Sync.

Many Events and Tasks with Large Notes

Tests adding many events and tasks with large notes.

Steps

1. Add many events and tasks—for example, 500 events and 500 tasks—with large notes to the computer.

2. Sync.
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This chapter contains miscellaneous tests that do not fit into any of the previous categories. Read “Common
Steps” for how to turn on data change alerts before running these tests.

Add Birthday to Calendar on the Device

Tests adding a birthday to a calendar on the device.

Steps

1. Add a contact to the device.

2. Add a birthday field to the contact on the device.

3. Save the changes.

4. If an “Add birthday to calendar?“ prompt appears on the device, click Yes.

5. Sync.

Verify that the event appears in iCal and is a yearly recurrent event.

Add Emoticons to Events on Device

Tests adding and removing emoticons on a device that supports the display of emoticons with some special
glyphs or pictures.

Steps

1. Add an emoticon—for example, a smiley—to each event on the device.

2. Sync.

3. Remove the emoticons from some events on the device.

4. Remove the emoticons from some different events on the computer.

5. Sync.
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Verify that the events are correctly modified in iCal and that each emoticon is displayed in iCal using the
corresponding ASCII text.
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This table describes the changes to iSync Manual Test Suite Guide.

NotesDate

New document that describes the manual tests that should be run before
shipping an iSync device plug-in.

2007-07-11
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